Security Cloud Firewall Management - Few services impacted by AWS outage

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 00:15 UTC

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 13:34 UTC

Monitoring

AWS has experienced a significant incidence starting at 6:40 UTC which impacted the following CDO services:
- SAL - services have been restored at 9:40 UTC
- FTDs managed by FDMs - services have been restored at 9:40 UTC
- FTD Dashboard reports - still impacted
Posted Oct 20, 2025 - 13:34 UTC